How to Install Ubiquiti UniFi Controller 5 on Ubuntu
Please share with your friends...
  • 2
  •  
  •  
  •  
  •  
  • 1
  •  
  •  
  •  
    3
    Shares


⇐ BackPage⇑ First

Installation Script

To automate the installation process, we have created a simple UniFi 5 Installation Script for Ubuntu that performs all the following actions for you:

  • Installs the latest Ubuntu package updates;
  • Installs Oracle Java 8;
  • Installs MongoDB 3.6;
  • Applies the MongoDB 3.x work-around required for UniFi 5; and
  • Installs the UniFi 5 controller software.

The UniFi 5 Installation Script for Ubuntu can also be run periodically to update the UniFi software and ensure you have the latest version installed.

UniFi 5 Installation Script for Ubuntu

The following steps explain how to use the UniFi 5 Installation Script for Ubuntu to perform an automated installation of the UniFi controller software.

  1. Clone the script directly from GitHub, using the following command:
    git clone https://gist.github.com/9f1958f12b1be024a04a44a2b44792d0.git ~/unifi5-ubuntu
  2. Execute the script, using the following command:
    sudo ~/unifi5-ubuntu/unifi5-ubuntu.sh

    When the installation is complete, return to the Setup Wizard instructions to finalise your installation.

⇐ BackPage⇑ First

Ubuntu and the Ubuntu logo are trademarks of Canonical Ltd. Linux® is a registered trademark of Linus Torvalds. Mongo, MongoDB and the MongoDB leaf logo are registered trademarks of MongoDB, Inc. Oracle and Java™ are trademarks of the Oracle Corporation. UBNT and UniFi® are trademarks of Ubiquiti Networks, Inc.
How to Install Ubiquiti UniFi Controller 5 on Ubuntu

Please share with your friends...
  • 2
  •  
  •  
  •  
  •  
  • 1
  •  
  •  
  •  
    3
    Shares
Tagged on:                                     

2 thoughts on “How to Install Ubiquiti UniFi Controller 5 on Ubuntu

  • 17/07/2018 at 10:58 AM
    Permalink

    So i have run into this error after executing your script can you help me with this?
    The following packages have unmet dependencies:
    unifi : Depends: mongodb-server (< 1:3.6.0) but it is not going to be installed or
    mongodb-10gen (< 3.6.0) but it is not installable or
    mongodb-org-server (< 3.6.0) but 3.6.6 is to be installed
    E: Unable to correct problems, you have held broken packages.

    Reply

Leave a Reply